diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 7 |
1 files changed, 7 insertions, 0 deletions
@@ -12,6 +12,13 @@ let # files if the requirements*.txt files change pythonEnv = poetry2nix.mkPoetryEnv { projectDir = ./util/nix; + overrides = poetry2nix.overrides.withDefaults (self: super: { + qmk = super.qmk.overridePythonAttrs(old: { + # Allow QMK CLI to run "bin/qmk" as a subprocess (the wrapper changes + # $PATH and breaks these invocations). + dontWrapPythonPrograms = true; + }); + }); }; in |